Skip to content
Main menu
  • Main page
  • Discover
  • Unexpected connections
  • Topics
  • Random article
  • Search
Your library
  • Saved articles
  • Recent discoveries
  • Rabbit-hole trails
Topic areas
  • Computer Science
  • Mathematics
  • Physics
  • Engineering
  • Biology
  • Economics
  • Curiosities
WikiholeDeeper into Wikipedia
EnglishEN
  • Saved
  • History

  • Article text and media come live from Wikipedia via the official MediaWiki API and are available under the Creative Commons Attribution-ShareAlike 4.0 License; additional terms may apply. Each article links to its source and revision.
  • WikiHole is an independent project and is not affiliated with the Wikimedia Foundation.
  • How ranking works
  • All topics
  • Reading history
  • Random article
  • MediaWiki API

Lightweight Directory Access Protocol

  • Article
  • Rabbit hole
  • Read
  • View history
Tools
Actions
  • Read
  • View history
General
  • Recent changes
  • Related articles
  • Random discovery
This article
Reading time
14 min
Topic
Computer Science
Quality
C-class
Views
3.4k in 14 days
Last edited
24 Oct 2026
Print/export
  • Printable version
In other projects
  • Wikidata item
From Wikipedia, the free encyclopedia
Rabbit hole:
  1. Lightweight Directory Access Protocol
Lightweight Directory Access Protocol
Network protocol supporting distributed directory information services
PurposeDirectory service
Introduction1993 (1993)
Based onX.500
Ports389 (ldap), 636 (ldaps)
RFCs4510, 4511

Lightweight Directory Access Protocol (LDAP /ˈɛl.dæp/) is an Internet protocol for accessing directory information services that act in accordance with X.500 data and service models.1 A full description of the protocol can be found in the "Lightweight Directory Access Protocol (LDAP) Technical Specification Road Map" RFC 4510 and its references.

Directory services play an important role in developing and Internet applications by allowing the sharing of information about users, systems, networks, services, and applications throughout the network. As examples, directory services may provide any organized set of records, often with a hierarchical structure, such as a corporate directory. Similarly, a is a list of subscribers with an address and a phone number.

Last edited
24 Oct 2026
intranet
2
email
telephone directory

A common use of LDAP is to provide a central place to store usernames and passwords. This allows many different applications and services to connect to the LDAP server to validate users.3

LDAP is a simpler (lightweight) subset of the standards in the X.500 series, particularly the X.511 Directory Access Protocol.45 Because of this relationship, LDAP is sometimes called X.500 Lite.6

The main components of LDAP are:

  • Protocol (RFC 4511): An application protocol that runs over an Internet Protocol (IP) network used to communicate with a directory service
  • Directory Information Models (RFC 4512): A specification for systems that implement directory services, i.e., "a collection of open systems cooperating to provide directory services" 7
  • Schema for User Applications (RFC 4519): A standard and extensible data schema for information to be help in a directory service - a "specification of attribute types and object classes intended for use by LDAP"8

Loading the rest of the article…

Recent changes

Rabbit hole

Where Lightweight Directory Access Protocol leads. Every connection below has a source: a link in this article, a shared Wikipedia category, or CirrusSearch text similarity. Articles already on your trail are left out.

General
  • Recent changes
  • Related articles
  • Random discovery
This article
Reading time
14 min
Topic
Computer Science
Quality
C-class
Views
3.4k in 14 days
Last edited
24 Oct 2026
Print/export
  • Printable version
In other projects
  • Wikidata item

Wikipedia did not return the list of recent edits.

View full revision history

Last edited
24 Oct 2026

The rest of this article could not be loaded.

Wikipedia is rate limiting us right now. Try again in a minute.
Try again

Related articles are unavailable right now.

Wikipedia is rate limiting us right now. Try again in a minute.